Hey Go Pro … Ever Hear of QA?

In this day, where more people are using high tech devices, you would think that manufacturers would be more stringent on QA testing.  Well, maybe my standards are too high, because I work in Customer Support for firewall and router devices?

Recently, Go Pro released new software (version 2.3) for their Quik application on PC and Mac desktops.  Soon after releasing that software, it failed to load any videos.  It would always give you a “Loading Media” message, and it stays there forever.  It still is able to import videos, but after it’s finished, you can’t view it.  You can’t even view videos that had been previously imported.  The prior release, 2.1, was fine.  I had 2.1 on my drive from previous upgrade … I uninstalled 2.3, and installed 2.1 … the result … I’m able to view my videos now.

This problem is not just isolated to me … I’ve seen many other people complain about this on their forum … Mac and Windows platforms of various OS’s.  I posted that downgrading to 2.1 resolved the issue, and others have commented that it works too.

So why do they release software, that is extremely easy to reproduce.  I mean, it happens on all OS’s.  So Go Pro, don’t you QA your software before you release it … like any other vendor out there?

Ok, rant over …

Advertisements
This entry was posted in rant, video and tagged , , . Bookmark the permalink.

One Response to Hey Go Pro … Ever Hear of QA?

  1. that’s crazy! Glad u were able to reinstall the old software! I would have been so mad!

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s